<!doctype html>
<!--[if lt IE 7]> <html class="no-js lt-ie9 lt-ie8 lt-ie7" lang="en-US"> <![endif]-->
<!--[if IE 7]>    <html class="no-js lt-ie9 lt-ie8" lang="en-US"> <![endif]-->
<!--[if IE 8]>    <html class="no-js lt-ie9" lang="en-US"> <![endif]-->
<!--[if IE 9]>    <html class="no-js lt-ie10" lang="en-US"> <![endif]-->
<!--[if gt IE 8]><!--> <html class="no-js" lang="en-US"> <!--<![endif]-->
<head>
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    <meta name='viewport' content='width=device-width, initial-scale=1, user-scalable=yes' />
    <link rel="profile" href="https://gmpg.org/xfn/11" />
    <link rel="pingback" href="https://newsdio.com/xmlrpc.php" />
    <meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />
			<script type="text/javascript">
              var jnews_ajax_url = '/?ajax-request=jnews'
			</script>
			<script type="text/javascript">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</script>
	<!-- This site is optimized with the Yoast SEO plugin v18.2 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>The Man Who Fell to Earth: Ejiofor talks about the upcoming film - NewsDio</title>
	<link rel="canonical" href="https://newsdio.com/the-man-who-fell-to-earth-ejiofor-talks-about-the-upcoming-film-2/175200/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="The Man Who Fell to Earth: Ejiofor talks about the upcoming film - NewsDio" />
	<meta property="og:description" content="David Bowie was a master of the arts. He was an incredible musician, actor, and artist. One of his most well-known films is The Man Who Fell to Earth. The movie tells the story of an alien who comes to Earth in search of water for his dying planet. The film is a masterpiece of [&hellip;]" />
	<meta property="og:url" content="https://newsdio.com/the-man-who-fell-to-earth-ejiofor-talks-about-the-upcoming-film-2/175200/" />
	<meta property="og:site_name" content="NewsDio" />
	<meta property="article:published_time" content="2022-03-14T21:03:40+00:00" />
	<meta property="article:modified_time" content="2022-03-14T20:04:45+00:00" />
	<meta name="twitter:card" content="summary_large_image" />
	<meta name="twitter:image" content="https://newsdio.com/wp-content/uploads/2022/03/The-Man-Who-Fell-to-Earth.webp" />
	<meta name="twitter:label1" content="Written by" />
	<meta name="twitter:data1" content="Farheen" />
	<meta name="twitter:label2" content="Est. reading time" />
	<meta name="twitter:data2" content="4 minutes" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://newsdio.com/#website","url":"https://newsdio.com/","name":"NewsDio","description":"The Internet Newspaper","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://newsdio.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://newsdio.com/the-man-who-fell-to-earth-ejiofor-talks-about-the-upcoming-film-2/175200/#primaryimage","inLanguage":"en-US","url":"https://newsdio.com/wp-content/uploads/2022/03/The-Man-Who-Fell-to-Earth.webp","contentUrl":"https://newsdio.com/wp-content/uploads/2022/03/The-Man-Who-Fell-to-Earth.webp","width":1600,"height":900,"caption":"The Man Who Fell to Earth"},{"@type":"WebPage","@id":"https://newsdio.com/the-man-who-fell-to-earth-ejiofor-talks-about-the-upcoming-film-2/175200/#webpage","url":"https://newsdio.com/the-man-who-fell-to-earth-ejiofor-talks-about-the-upcoming-film-2/175200/","name":"The Man Who Fell to Earth: Ejiofor talks about the upcoming film - NewsDio","isPartOf":{"@id":"https://newsdio.com/#website"},"primaryImageOfPage":{"@id":"https://newsdio.com/the-man-who-fell-to-earth-ejiofor-talks-about-the-upcoming-film-2/175200/#primaryimage"},"datePublished":"2022-03-14T21:03:40+00:00","dateModified":"2022-03-14T20:04:45+00:00","author":{"@id":"https://newsdio.com/#/schema/person/22e8e426289b50aaabf79374a43ff90e"},"breadcrumb":{"@id":"https://newsdio.com/the-man-who-fell-to-earth-ejiofor-talks-about-the-upcoming-film-2/175200/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://newsdio.com/the-man-who-fell-to-earth-ejiofor-talks-about-the-upcoming-film-2/175200/"]}]},{"@type":"BreadcrumbList","@id":"https://newsdio.com/the-man-who-fell-to-earth-ejiofor-talks-about-the-upcoming-film-2/175200/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://newsdio.com/"},{"@type":"ListItem","position":2,"name":"The Man Who Fell to Earth: Ejiofor talks about the upcoming film"}]},{"@type":"Person","@id":"https://newsdio.com/#/schema/person/22e8e426289b50aaabf79374a43ff90e","name":"Farheen","image":{"@type":"ImageObject","@id":"https://newsdio.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/e58af1a6d4967afef72053dd585e2674?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/e58af1a6d4967afef72053dd585e2674?s=96&d=mm&r=g","caption":"Farheen"},"description":"Farheen was born in Kansas City, Missouri to two community-college professors—her mother taught reading; her father, film. Thus she spent an inordinate amount of her youth nosing through books and watching movies. She has happy memories of having A Wrinkle in Time pried from her hands at the dinner table, and also of seeing Alien, Psycho and Bonnie and Clyde at a questionable age (like, seven). She Knows The art of Writing News","url":"https://newsdio.com/author/farheen/"}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='preconnect' href='https://fonts.gstatic.com' />
<link rel="alternate" type="application/rss+xml" title="NewsDio &raquo; Feed" href="https://newsdio.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="NewsDio &raquo; Comments Feed" href="https://newsdio.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="NewsDio &raquo; The Man Who Fell to Earth: Ejiofor talks about the upcoming film Comments Feed" href="https://newsdio.com/the-man-who-fell-to-earth-ejiofor-talks-about-the-upcoming-film-2/175200/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/newsdio.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8.4"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://newsdio.com/wp-includes/css/dist/block-library/style.min.css?ver=5.8.4' type='text/css' media='all' />
<link rel='stylesheet' id='easy_author_image-css'  href='https://newsdio.com/wp-content/plugins/easy-author-image/css/easy-author-image.css?ver=5.8.4' type='text/css' media='all' />
<link rel='stylesheet' id='jeg_customizer_font-css'  href='//fonts.googleapis.com/css?family=Lato%3Aregular%2C700%7CMontserrat%3Aregular%2C700&#038;display=swap&#038;ver=1.2.6' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-frontend-css'  href='https://newsdio.com/wp-content/themes/jnews/assets/dist/frontend.min.css?ver=10.0.9' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-elementor-css'  href='https://newsdio.com/wp-content/themes/jnews/assets/css/elementor-frontend.css?ver=10.0.9' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-style-css'  href='https://newsdio.com/wp-content/themes/jnews/style.css?ver=10.0.9' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-darkmode-css'  href='https://newsdio.com/wp-content/themes/jnews/assets/css/darkmode.css?ver=10.0.9' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-scheme-css'  href='https://newsdio.com/wp-content/themes/jnews/data/import/newsplus/scheme.css?ver=10.0.9' type='text/css' media='all' />
<link rel='stylesheet' id='jnews-select-share-css'  href='https://newsdio.com/wp-content/plugins/jnews-social-share/assets/css/plugin.css' type='text/css' media='all' />
<script type='text/javascript' src='https://newsdio.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://newsdio.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<link rel="https://api.w.org/" href="https://newsdio.com/wp-json/" /><link rel="alternate" type="application/json" href="https://newsdio.com/wp-json/wp/v2/posts/175200" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://newsdio.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://newsdio.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.8.4" />
<link rel='shortlink' href='https://newsdio.com/?p=175200' />
<link rel="alternate" type="application/json+oembed" href="https://newsdio.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnewsdio.com%2Fthe-man-who-fell-to-earth-ejiofor-talks-about-the-upcoming-film-2%2F175200%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://newsdio.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnewsdio.com%2Fthe-man-who-fell-to-earth-ejiofor-talks-about-the-upcoming-film-2%2F175200%2F&#038;format=xml" />
<meta name="bm-site-verification" content="a884813bcae9206467215c3f00dfa6d13cfac394">
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-163491670-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-163491670-1');
</script>
<meta name="bm-site-verification" content="a884813bcae9206467215c3f00dfa6d13cfac394">
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","@id":"https:\/\/newsdio.com\/#organization","url":"https:\/\/newsdio.com\/","name":"","logo":{"@type":"ImageObject","url":""},"sameAs":["http:\/\/facebook.com","http:\/\/twitter.com"]}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"https:\/\/newsdio.com\/#website","url":"https:\/\/newsdio.com\/","name":"","potentialAction":{"@type":"SearchAction","target":"https:\/\/newsdio.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<link rel="icon" href="https://newsdio.com/wp-content/uploads/2021/09/cropped-Untitled-design-32x32.png" sizes="32x32" />
<link rel="icon" href="https://newsdio.com/wp-content/uploads/2021/09/cropped-Untitled-design-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://newsdio.com/wp-content/uploads/2021/09/cropped-Untitled-design-180x180.png" />
<meta name="msapplication-TileImage" content="https://newsdio.com/wp-content/uploads/2021/09/cropped-Untitled-design-270x270.png" />
<script>Auto ads


</script><style id="jeg_dynamic_css" type="text/css" data-type="jeg_custom-css">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</style></head>
<body class="post-template-default single single-post postid-175200 single-format-standard wp-embed-responsive jeg_toggle_dark jeg_single_tpl_2 jnews jnews_boxed_container jnews_boxed_container_shadow jsc_normal elementor-default elementor-kit-151634">

    
    
    <div class="jeg_ad jeg_ad_top jnews_header_top_ads">
        <div class='ads-wrapper  '><div class='ads_code'><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-6893006633895851"
     crossorigin="anonymous"></script>
<!-- desplayads-newsdio-1 -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-6893006633895851"
     data-ad-slot="7077722352"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div><div class='ads-text'>ADVERTISEMENT</div></div>    </div>

    <!-- The Main Wrapper
    ============================================= -->
    <div class="jeg_viewport">

        
        <div class="jeg_header_wrapper">
            <div class="jeg_header_instagram_wrapper">
    </div>

<!-- HEADER -->
<div class="jeg_header normal">
    <div class="jeg_midbar jeg_container normal">
    <div class="container">
        <div class="jeg_nav_row">
            
                <div class="jeg_nav_col jeg_nav_left jeg_nav_grow">
                    <div class="item_wrap jeg_nav_alignleft">
                        <div class="jeg_nav_item jeg_logo jeg_desktop_logo">
			<div class="site-title">
			<a href="https://newsdio.com/" style="padding: 0px 0px 0px 0px;">
				<img class='jeg_logo_img' src="https://newsdio.com/wp-content/uploads/2021/10/images.png" srcset="https://newsdio.com/wp-content/uploads/2021/10/images.png 1x, https://newsdio.com/wp-content/uploads/2021/09/main-logo.png 2x" alt="NewsDio"data-light-src="https://newsdio.com/wp-content/uploads/2021/10/images.png" data-light-srcset="https://newsdio.com/wp-content/uploads/2021/10/images.png 1x, https://newsdio.com/wp-content/uploads/2021/09/main-logo.png 2x" data-dark-src="https://newsdio.com/wp-content/uploads/2021/09/main-logo.png" data-dark-srcset="https://newsdio.com/wp-content/uploads/2021/09/main-logo.png 1x, https://newsdio.com/wp-content/uploads/2021/09/main-logo.png 2x">			</a>
		</div>
	</div>
<div class="jeg_nav_item jeg_ad jeg_ad_top jnews_header_ads">
    <div class='ads-wrapper  '></div></div>                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_center jeg_nav_normal">
                    <div class="item_wrap jeg_nav_aligncenter">
                                            </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignright">
                        <div class="jeg_separator separator5"></div>			<div
				class="jeg_nav_item socials_widget jeg_social_icon_block nobg">
				<a href="https://facebook.com" target='_blank' rel='external noopener nofollow' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com" target='_blank' rel='external noopener nofollow' class="jeg_twitter"><i class="fa fa-twitter"></i> </a>			</div>
			<div class="jeg_nav_item jeg_dark_mode">
                    <label class="dark_mode_switch">
                        <input type="checkbox" class="jeg_dark_mode_toggle" >
                        <span class="slider round"></span>
                    </label>
                 </div>                    </div>
                </div>

                        </div>
    </div>
</div><div class="jeg_bottombar jeg_navbar jeg_container jeg_navbar_wrapper jeg_navbar_normal jeg_navbar_shadow jeg_navbar_normal">
    <div class="container">
        <div class="jeg_nav_row">
            
                <div class="jeg_nav_col jeg_nav_left jeg_nav_grow">
                    <div class="item_wrap jeg_nav_alignleft">
                        <div class="jeg_nav_item jeg_main_menu_wrapper">
<div class="jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_5" data-animation="animateTransform"><li id="menu-item-163392" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-163392 bgnav" data-item-row="default" ><a href="https://newsdio.com/">Home</a></li>
<li id="menu-item-163394" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-163394 bgnav" data-item-row="default" ><a href="https://newsdio.com/category/entertainment/">Entertainment</a></li>
<li id="menu-item-163395" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163395 bgnav" data-item-row="default" ><a href="https://newsdio.com/category/tv-shows/">TV SHOWS</a></li>
<li id="menu-item-163396" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163396 bgnav" data-item-row="default" ><a href="https://newsdio.com/category/technology/">Technology</a></li>
<li id="menu-item-163397" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163397 bgnav" data-item-row="default" ><a href="https://newsdio.com/category/featured/movies/">Movies</a></li>
<li id="menu-item-163398" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163398 bgnav" data-item-row="default" ><a href="https://newsdio.com/category/news/">News</a></li>
<li id="menu-item-163399" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163399 bgnav" data-item-row="default" ><a href="https://newsdio.com/category/finance/">Finance</a></li>
<li id="menu-item-163400" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163400 bgnav" data-item-row="default" ><a href="https://newsdio.com/category/health/">Health</a></li>
<li id="menu-item-167992" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-167992 bgnav" data-item-row="default" ><a href="https://newsdio.com/category/gaming/">Gaming</a></li>
<li id="menu-item-163393" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-163393 bgnav" data-item-row="default" ><a href="https://newsdio.com/write-for-us/">Write for Us</a></li>
</ul></div></div>
                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_center jeg_nav_normal">
                    <div class="item_wrap jeg_nav_aligncenter">
                                            </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignright">
                                            </div>
                </div>

                        </div>
    </div>
</div></div><!-- /.jeg_header -->        </div>

        <div class="jeg_header_sticky">
            <div class="sticky_blankspace"></div>
<div class="jeg_header normal">
    <div class="jeg_container">
        <div data-mode="scroll" class="jeg_stickybar jeg_navbar jeg_navbar_wrapper jeg_navbar_normal jeg_navbar_normal">
            <div class="container">
    <div class="jeg_nav_row">
        
            <div class="jeg_nav_col jeg_nav_left jeg_nav_grow">
                <div class="item_wrap jeg_nav_alignleft">
                    <div class="jeg_nav_item jeg_main_menu_wrapper">
<div class="jeg_mainmenu_wrap"><ul class="jeg_menu jeg_main_menu jeg_menu_style_5" data-animation="animateTransform"><li id="menu-item-163392" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-163392 bgnav" data-item-row="default" ><a href="https://newsdio.com/">Home</a></li>
<li id="menu-item-163394" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-163394 bgnav" data-item-row="default" ><a href="https://newsdio.com/category/entertainment/">Entertainment</a></li>
<li id="menu-item-163395" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163395 bgnav" data-item-row="default" ><a href="https://newsdio.com/category/tv-shows/">TV SHOWS</a></li>
<li id="menu-item-163396" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163396 bgnav" data-item-row="default" ><a href="https://newsdio.com/category/technology/">Technology</a></li>
<li id="menu-item-163397" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163397 bgnav" data-item-row="default" ><a href="https://newsdio.com/category/featured/movies/">Movies</a></li>
<li id="menu-item-163398" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163398 bgnav" data-item-row="default" ><a href="https://newsdio.com/category/news/">News</a></li>
<li id="menu-item-163399" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163399 bgnav" data-item-row="default" ><a href="https://newsdio.com/category/finance/">Finance</a></li>
<li id="menu-item-163400" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163400 bgnav" data-item-row="default" ><a href="https://newsdio.com/category/health/">Health</a></li>
<li id="menu-item-167992" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-167992 bgnav" data-item-row="default" ><a href="https://newsdio.com/category/gaming/">Gaming</a></li>
<li id="menu-item-163393" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-163393 bgnav" data-item-row="default" ><a href="https://newsdio.com/write-for-us/">Write for Us</a></li>
</ul></div></div>
                </div>
            </div>

            
            <div class="jeg_nav_col jeg_nav_center jeg_nav_normal">
                <div class="item_wrap jeg_nav_aligncenter">
                                    </div>
            </div>

            
            <div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
                <div class="item_wrap jeg_nav_alignright">
                    <!-- Search Icon -->
<div class="jeg_nav_item jeg_search_wrapper search_icon jeg_search_popup_expand">
    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
    <form action="https://newsdio.com/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button aria-label="Search Button" type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div></div>                </div>
            </div>

                </div>
</div>        </div>
    </div>
</div>
        </div>

        <div class="jeg_navbar_mobile_wrapper">
            <div class="jeg_navbar_mobile" data-mode="scroll">
    <div class="jeg_mobile_bottombar jeg_mobile_midbar jeg_container dark">
    <div class="container">
        <div class="jeg_nav_row">
            
                <div class="jeg_nav_col jeg_nav_left jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignleft">
                        <div class="jeg_nav_item">
    <a href="#" class="toggle_btn jeg_mobile_toggle"><i class="fa fa-bars"></i></a>
</div>                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_center jeg_nav_grow">
                    <div class="item_wrap jeg_nav_aligncenter">
                        <div class="jeg_nav_item jeg_mobile_logo">
			<div class="site-title">
	    	<a href="https://newsdio.com/">
		        <img class='jeg_logo_img' src="" srcset=" 1x, https://newsdio.com/wp-content/uploads/2021/10/images.png 2x" alt="NewsDio"data-light-src="" data-light-srcset=" 1x, https://newsdio.com/wp-content/uploads/2021/10/images.png 2x" data-dark-src="https://newsdio.com/wp-content/uploads/2021/09/main-logo.png" data-dark-srcset="https://newsdio.com/wp-content/uploads/2021/09/main-logo.png 1x, https://newsdio.com/wp-content/uploads/2021/09/main-logo.png 2x">		    </a>
	    </div>
	</div>                    </div>
                </div>

                
                <div class="jeg_nav_col jeg_nav_right jeg_nav_normal">
                    <div class="item_wrap jeg_nav_alignright">
                        <div class="jeg_nav_item jeg_search_wrapper jeg_search_popup_expand">
    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
	<form action="https://newsdio.com/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button aria-label="Search Button" type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div></div>                    </div>
                </div>

                        </div>
    </div>
</div></div>
<div class="sticky_blankspace" style="height: 60px;"></div>        </div>

            <div class="post-wrapper">

        <div class="post-wrap post-autoload "  data-url="https://newsdio.com/the-man-who-fell-to-earth-ejiofor-talks-about-the-upcoming-film-2/175200/" data-title="The Man Who Fell to Earth: Ejiofor talks about the upcoming film" data-id="175200"  data-prev="https://newsdio.com/sonic-the-hedgehog-2-a-retro-classic-film-with-a-modern-twist/175196/" >

            
            <div class="jeg_main ">
                <div class="jeg_container">
                    <div class="jeg_content jeg_singlepage">
	<div class="container">

		<div class="jeg_ad jeg_article_top jnews_article_top_ads">
			<div class='ads-wrapper  '><div class="ads_google_ads">
                            <style type='text/css' scoped>
                                .adsslot_bmdf3e0DTo{ width:970px !important; height:90px !important; }
@media (max-width:1199px) { .adsslot_bmdf3e0DTo{ width:468px !important; height:60px !important; } }
@media (max-width:767px) { .adsslot_bmdf3e0DTo{ width:320px !important; height:50px !important; } }

                            </style>
                            <ins class="adsbygoogle adsslot_bmdf3e0DTo" style="display:inline-block;" data-ad-client="ca-pub-6893006633895851" data-ad-slot="8914835329"></ins>
                            <script async defer src='//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js'></script>
                            <script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
                        </div><div class='ads-text'>ADVERTISEMENT</div></div>		</div>

		
						<div class="jeg_breadcrumbs jeg_breadcrumb_container">
				<div id="breadcrumbs"><span class="">
                <a href="https://newsdio.com">Home</a>
            </span><i class="fa fa-angle-right"></i><span class="breadcrumb_last_link">
                <a href="https://newsdio.com/category/entertainment/">Entertainment</a>
            </span></div>			</div>
			
			<div class="entry-header">
				
				<h1 class="jeg_post_title">The Man Who Fell to Earth: Ejiofor talks about the upcoming film</h1>

				
				<div class="jeg_meta_container"><div class="jeg_post_meta jeg_post_meta_2">
    <div class="meta_left">
                                    <div class="jeg_meta_author">
                    <img class="avatar avatar-80 photo" width="64" height="64" src="https://newsdio.com/wp-content/uploads/2022/02/Screenshot-28.png"/>                    <span class="meta_text">by</span>
                    <a href="https://newsdio.com/author/farheen/">Farheen</a>                </div>
                    
                    <div class="jeg_meta_date">
                <a href="https://newsdio.com/the-man-who-fell-to-earth-ejiofor-talks-about-the-upcoming-film-2/175200/">March 14, 2022 5:03 pm EDT</a>
            </div>
        
        
        <div class="jeg_meta_reading_time">
			            <span>
			            	Reading Time: 3 mins read
			            </span>
			        </div>    </div>

	<div class="meta_right">
					</div>
</div>
</div>
			</div>

			<div class="row">
				<div class="jeg_main_content col-md-8">

					<div class="jeg_inner_content">
						<div class="jeg_featured featured_image"><a href="https://newsdio.com/wp-content/uploads/2022/03/The-Man-Who-Fell-to-Earth.webp"><div class="thumbnail-container" style="padding-bottom:71.467%"><img width="750" height="536" src="https://newsdio.com/wp-content/uploads/2022/03/The-Man-Who-Fell-to-Earth-750x536.webp" class="attachment-jnews-750x536 size-jnews-750x536 wp-post-image" alt="The Man Who Fell to Earth" srcset="https://newsdio.com/wp-content/uploads/2022/03/The-Man-Who-Fell-to-Earth-750x536.webp 750w, https://newsdio.com/wp-content/uploads/2022/03/The-Man-Who-Fell-to-Earth-120x86.webp 120w, https://newsdio.com/wp-content/uploads/2022/03/The-Man-Who-Fell-to-Earth-350x250.webp 350w, https://newsdio.com/wp-content/uploads/2022/03/The-Man-Who-Fell-to-Earth-1140x815.webp 1140w" sizes="(max-width: 750px) 100vw, 750px" /></div></a></div>
						<div class="jeg_share_top_container"></div>
						<div class="jeg_ad jeg_article jnews_content_top_ads "><div class='ads-wrapper  '><div class="ads_google_ads">
                            <style type='text/css' scoped>
                                .adsslot_uyvHtYeMdc{ width:728px !important; height:90px !important; }
@media (max-width:1199px) { .adsslot_uyvHtYeMdc{ width:468px !important; height:60px !important; } }
@media (max-width:767px) { .adsslot_uyvHtYeMdc{ width:320px !important; height:50px !important; } }

                            </style>
                            <ins class="adsbygoogle adsslot_uyvHtYeMdc" style="display:inline-block;" data-ad-client="ca-pub-6893006633895851" data-ad-slot="3313541086"></ins>
                            <script async defer src='//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js'></script>
                            <script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
                        </div></div></div>
						<div class="entry-content no-share">
							<div class="jeg_share_button share-float jeg_sticky_share clearfix share-monocrhome">
								<div class="jeg_share_float_container"></div>							</div>

							<div class="content-inner  jeg_link_underline">
								<p>David Bowie was a master of the arts. He was an incredible musician, actor, and artist. One of his most well-known films is The Man Who Fell to Earth. The movie tells the story of an alien who comes to Earth in search of water for his dying planet. The film is a masterpiece of science fiction and is still popular today.</p>
<p>Based on Bowie&#8217;s version of The Man Who Fell to Earth and Walter Tevis&#8217;s novel of the same name a new version of “The Man Who Fell to Earth” is going to come on Showtime.</p>
<h2><strong>What is the new version of The Man Who Fell to Earth about?</strong></h2>
<p>In the coming series “ The Man Who Fell to Earth,” Chiwetel Ejiofor stars as an extraterrestrial who travels to Earth after his home earth dies. He seeks out scientist Justin Falls (Naomie Harris) to protect both his people and hers.</p><div class="jeg_ad jeg_ad_article jnews_content_inline_2_ads  "><div class='ads-wrapper align-center '><div class="ads_google_ads">
                            <style type='text/css' scoped>
                                .adsslot_Oy3bKxMdYo{ width:728px !important; height:90px !important; }
@media (max-width:1199px) { .adsslot_Oy3bKxMdYo{ width:468px !important; height:60px !important; } }
@media (max-width:767px) { .adsslot_Oy3bKxMdYo{ width:320px !important; height:50px !important; } }

                            </style>
                            <ins class="adsbygoogle adsslot_Oy3bKxMdYo" style="display:inline-block;" data-ad-client="ca-pub-6893006633895851" data-ad-slot="7037381879"></ins>
                            <script async defer src='//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js'></script>
                            <script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
                        </div></div></div>
<h2><strong>Ejiofor talks about the upcoming film</strong></h2>
<p>Ejiofor, who additionally serves as executive producer, has previously told IndieWire that he strives to represent a variety of storytelling styles onscreen.</p><div class='jnews_inline_related_post_wrapper left'>
                        <div class='jnews_inline_related_post'>
                <div  class="jeg_postblock_28 jeg_postblock jeg_module_hook jeg_pagination_disable jeg_col_2o3 jnews_module_175200_1_622fe718901ed   " data-unique="jnews_module_175200_1_622fe718901ed">
					<div class="jeg_block_heading jeg_block_heading_6 jeg_subcat_right">
                     <h3 class="jeg_block_title"><span>RELATED POSTS</span></h3>
                     
                 </div>
					<div class="jeg_block_container">
                    
                    <div class="jeg_posts ">
                    <div class="jeg_postsmall jeg_load_more_flag">
                        <article class="jeg_post jeg_pl_xs_4 format-standard">
                    <div class="jeg_postblock_content">
                        <h3 class="jeg_post_title">
                            <a href="https://newsdio.com/batman-the-dark-knight-of-gotham-city/175203/">Batman: The Dark Knight of Gotham City</a>
                        </h3>
                        
                    </div>
                </article><article class="jeg_post jeg_pl_xs_4 format-standard">
                    <div class="jeg_postblock_content">
                        <h3 class="jeg_post_title">
                            <a href="https://newsdio.com/the-mysterious-and-engaging-world-of-the-umbrella-academy/175193/">The Mysterious and Engaging World of The Umbrella Academy</a>
                        </h3>
                        
                    </div>
                </article><article class="jeg_post jeg_pl_xs_4 format-standard">
                    <div class="jeg_postblock_content">
                        <h3 class="jeg_post_title">
                            <a href="https://newsdio.com/the-best-matt-damon-movies-of-all-time/175206/">The Best Matt Damon Movies of All-Time</a>
                        </h3>
                        
                    </div>
                </article>
                    </div>
                </div>
                    <div class='module-overlay'>
				    <div class='preloader_type preloader_dot'>
				        <div class="module-preloader jeg_preloader dot">
				            <span></span><span></span><span></span>
				        </div>
				        <div class="module-preloader jeg_preloader circle">
				            <div class="jnews_preloader_circle_outer">
				                <div class="jnews_preloader_circle_inner"></div>
				            </div>
				        </div>
				        <div class="module-preloader jeg_preloader square">
				            <div class="jeg_square">
				                <div class="jeg_square_inner"></div>
				            </div>
				        </div>
				    </div>
				</div>
                </div>
                <div class="jeg_block_navigation">
                    <div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div>
                    
                    
                </div>
					
					<script>var jnews_module_175200_1_622fe718901ed = {"header_icon":"","first_title":"RELATED POSTS","second_title":"","url":"","header_type":"heading_6","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"All","post_type":"post","content_type":"all","number_post":"3","post_offset":0,"unique_content":"unique2","include_post":"","exclude_post":"175209,175196,175198,175200","include_category":"22903","exclude_category":"","include_author":"","include_tag":"","exclude_tag":"","sort_by":"latest","show_date":"","date_format":"default","date_format_custom":"Y\/m\/d","pagination_mode":"disable","pagination_nextprev_showtext":"","pagination_number_post":"3","pagination_scroll_limit":0,"ads_type":"disable","ads_position":1,"ads_random":"","ads_image":"","ads_image_tablet":"","ads_image_phone":"","ads_image_link":"","ads_image_alt":"","ads_image_new_tab":"","google_publisher_id":"","google_slot_id":"","google_desktop":"auto","google_tab":"auto","google_phone":"auto","content":"","ads_bottom_text":"","boxed":"","boxed_shadow":"","show_border":"","el_id":"","el_class":"","scheme":"","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","paged":1,"column_class":"jeg_col_2o3","class":"jnews_block_28"};</script>
				</div>
            </div>
                    </div>
<p>I suppose it’s a truly exciting time for multiplicity in cinema,” Ejiofor said during IndieWire’s 2019 Sundance Studio. “ Of course, all these diverse viewpoints from very powerful media industries and these distinct points of view actually affect the nature and the psychology of the societies that we’re all in, and that’s been part of the matter — that when things are related from only one point of view, that it kind of shuts down the conversation across the board in a cultural setting.</p>
<p>Ejiofor continued, “ People don’t have genuine, authentic sources from diverse places, different communities, distinct people’s point of view, or their lives.”</p>
<h2><strong>Who is in the cast of The Man Who Fell to Earth?</strong></h2>
<p>The upcoming series is executively produced by Alex Kurtzman, Jenny Lumet, John Hlavin, Sarah Timberman, Carl Beverly, Heather Kadin, Aaron Baiers, and StudioCanal’s Rola Bauer and Françoise Guyonnet. It stars  Chiwetel Ejiofor and Naomie Harris. The series also has Jimmi Simpson, Rob Delaney, Sonya Cassidy, Joana Ribeiro, Annelle Olaleye, Kate Mulgrew, Clarke Peters, and Bill Nighy onboard.</p>
<h2><strong>What is the cast saying?</strong></h2>
<p>Chiwetel Ejiofor said, “I’ve been a fan of Bowie since I was a teenager so this is really a dream come true. I can’t wait to explore the character of Thomas Newton in further depth and to bring his story to life.”</p><div class="jeg_ad jeg_ad_article jnews_content_inline_ads  "><div class='ads-wrapper align-center '><div class="ads_google_ads">
                            <style type='text/css' scoped>
                                .adsslot_bGZUAYfqIL{ width:728px !important; height:90px !important; }
@media (max-width:1199px) { .adsslot_bGZUAYfqIL{ width:468px !important; height:60px !important; } }
@media (max-width:767px) { .adsslot_bGZUAYfqIL{ width:320px !important; height:50px !important; } }

                            </style>
                            <ins class="adsbygoogle adsslot_bGZUAYfqIL" style="display:inline-block;" data-ad-client="ca-pub-6893006633895851" data-ad-slot="9015067120"></ins>
                            <script async defer src='//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js'></script>
                            <script>(adsbygoogle = window.adsbygoogle || []).push({});</script>
                        </div><div class='ads-text'>ADVERTISEMENT</div></div></div>
<p>Naomie Harris said, “I am thrilled to be joining this incredible cast and working with such an amazing team on The Man Who Fell To Earth. This is a unique opportunity to explore one of the most enigmatic characters in British fiction. As an actor, there are very few opportunities that offer as much complexity and challenge as playing someone who is both human and otherworldly, which is what makes The Man Who Fell To Earth so fascinating.”</p>
<h2><strong>Why you should watch The Man Who Fell to Earth?</strong></h2>
<p>The Man Who Fell to Earth is one of the greatest pieces of science fiction and cinema. The story, acting, and directing are all stellar. The film is a must-watch for anyone who loves sci-fi or great films. David Bowie&#8217;s The Man Who Fell to Earth: A Masterpiece of Sci-Fi and its Ejiofor&#8217;s rebooted version will be amazing too.</p>
<h2><strong>What was classic The Man Who Fell to Earth about?</strong></h2>
<p>When The Man Who Fell to Earth was released in 1976, it was met with mixed reviews from critics. However, over time the film has become a masterpiece of sci-fi and cinema. The story follows an alien (played by David Bowie) who comes to Earth seeking water for his drought-ridden home planet. He becomes entangled in a web of deceit and betrayal as he tries to keep his true identity a secret and find a way home. The acting, writing, and directing are all stellar. The film is a must-watch for anyone who loves sci-fi or great films.</p>
<p>The Man Who Fell to Earth is a must-watch for anyone who loves sci-fi or great films. The acting, writing, and directing are all stellar.</p>
<p>Ejiofor&#8217;s rebooted version of The Man Who Fell to Earth will be released on  April 24 2022 and is already generating buzz. The new version stars Ejiofor in the lead role with Naomie Harris, Jimmi Simpson, Rob Delaney also appearing in the cast. It&#8217;s sure to be another masterpiece so make sure to check it out when it comes out!</p>
								
								
															</div>


						</div>
						<div class="jeg_share_bottom_container"><div class="jeg_share_button share-bottom clearfix">
                <div class="jeg_sharelist">
                    <a href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fnewsdio.com%2Fthe-man-who-fell-to-earth-ejiofor-talks-about-the-upcoming-film-2%2F175200%2F" rel='nofollow' class="jeg_btn-facebook expanded"><i class="fa fa-facebook-official"></i><span>Share</span></a><a href="https://twitter.com/intent/tweet?text=The%20Man%20Who%20Fell%20to%20Earth%3A%20Ejiofor%20talks%20about%20the%20upcoming%20film&url=https%3A%2F%2Fnewsdio.com%2Fthe-man-who-fell-to-earth-ejiofor-talks-about-the-upcoming-film-2%2F175200%2F" rel='nofollow' class="jeg_btn-twitter expanded"><i class="fa fa-twitter"></i><span>Tweet</span></a>
                    <div class="share-secondary">
                    <a href="https://www.linkedin.com/shareArticle?url=https%3A%2F%2Fnewsdio.com%2Fthe-man-who-fell-to-earth-ejiofor-talks-about-the-upcoming-film-2%2F175200%2F&title=The%20Man%20Who%20Fell%20to%20Earth%3A%20Ejiofor%20talks%20about%20the%20upcoming%20film" rel='nofollow'  class="jeg_btn-linkedin "><i class="fa fa-linkedin"></i></a><a href="https://www.pinterest.com/pin/create/bookmarklet/?pinFave=1&url=https%3A%2F%2Fnewsdio.com%2Fthe-man-who-fell-to-earth-ejiofor-talks-about-the-upcoming-film-2%2F175200%2F&media=https://newsdio.com/wp-content/uploads/2022/03/The-Man-Who-Fell-to-Earth.webp&description=The%20Man%20Who%20Fell%20to%20Earth%3A%20Ejiofor%20talks%20about%20the%20upcoming%20film" rel='nofollow'  class="jeg_btn-pinterest "><i class="fa fa-pinterest"></i></a>
                </div>
                <a href="#" class="jeg_btn-toggle"><i class="fa fa-share"></i></a>
                </div>
            </div></div>
												<div class="jeg_ad jeg_article jnews_content_bottom_ads "><div class='ads-wrapper  '></div></div><div class="jnews_prev_next_container"></div><div class="jnews_author_box_container ">
	<div class="jeg_authorbox">
		<div class="jeg_author_image">
			<img class="avatar avatar-80 photo" width="64" height="64" src="https://newsdio.com/wp-content/uploads/2022/02/Screenshot-28.png"/>		</div>
		<div class="jeg_author_content">
			<h3 class="jeg_author_name">
				<a href="https://newsdio.com/author/farheen/">
					Farheen				</a>
			</h3>
			<p class="jeg_author_desc">
				Farheen was born in Kansas City, Missouri to two community-college professors—her mother taught reading; her father, film. Thus she spent an inordinate amount of her youth nosing through books and watching movies. She has happy memories of having A Wrinkle in Time pried from her hands at the dinner table, and also of seeing Alien, Psycho and Bonnie and Clyde at a questionable age (like, seven). She Knows The art of Writing News			</p>

							<div class="jeg_author_socials">
									</div>
			
		</div>
	</div>
</div><div class="jnews_related_post_container"><div  class="jeg_postblock_27 jeg_postblock_blog_2 jeg_postblock jeg_module_hook jeg_pagination_disable jeg_col_2o3 jnews_module_175200_2_622fe71893a44   " data-unique="jnews_module_175200_2_622fe71893a44">
                    <div class="jeg_block_heading jeg_block_heading_7 jeg_subcat_right">
                     <h3 class="jeg_block_title"><span>Related<strong> Posts</strong></span></h3>
                     
                 </div>
                    <div class="jeg_block_container">
                    
                    <div class="jeg_posts jeg_load_more_flag"><article class="jeg_post jeg_pl_md_4 format-standard">
                    <div class="jeg_thumb">
                        
                        <a href="https://newsdio.com/obi-wan-kenobi-what-we-know-about-the-upcoming-series-so-far/175209/"><div class="thumbnail-container  size-715 "><img width="350" height="250" src="https://newsdio.com/wp-content/uploads/2022/03/Obi-Wan-Kenobi-350x250.jpg" class="attachment-jnews-350x250 size-jnews-350x250 wp-post-image" alt="Obi-Wan Kenobi" srcset="https://newsdio.com/wp-content/uploads/2022/03/Obi-Wan-Kenobi-350x250.jpg 350w, https://newsdio.com/wp-content/uploads/2022/03/Obi-Wan-Kenobi-120x86.jpg 120w, https://newsdio.com/wp-content/uploads/2022/03/Obi-Wan-Kenobi-750x536.jpg 750w" sizes="(max-width: 350px) 100vw, 350px" /></div></a>
                    </div>
                    <div class="jeg_postblock_content">
                        <div class="jeg_post_category">
                            <span><a href="https://newsdio.com/category/entertainment/">Entertainment</a></span>
                        </div>
                        <h3 class="jeg_post_title"><a href="https://newsdio.com/obi-wan-kenobi-what-we-know-about-the-upcoming-series-so-far/175209/" >Obi-Wan Kenobi: What We Know About the Upcoming Series So Far</a></h3>
                        <div class="jeg_post_meta">
                            
                            <div class="jeg_meta_date"><i class="fa fa-clock-o"></i> March 14, 2022 9:07 pm EDT</div>
                        </div>
                        <div class="jeg_post_excerpt">
                            <p>...</p>
                        </div>
                    </div>
                </article><article class="jeg_post jeg_pl_md_4 format-standard">
                    <div class="jeg_thumb">
                        
                        <a href="https://newsdio.com/sonic-the-hedgehog-2-a-retro-classic-film-with-a-modern-twist/175196/"><div class="thumbnail-container  size-715 "><img width="297" height="169" src="https://newsdio.com/wp-content/uploads/2022/03/Sonic-the-Hedgehog-2-1.jpg" class="attachment-jnews-350x250 size-jnews-350x250 wp-post-image" alt="Sonic The Hedgehog 2" /></div></a>
                    </div>
                    <div class="jeg_postblock_content">
                        <div class="jeg_post_category">
                            <span><a href="https://newsdio.com/category/entertainment/">Entertainment</a></span>
                        </div>
                        <h3 class="jeg_post_title"><a href="https://newsdio.com/sonic-the-hedgehog-2-a-retro-classic-film-with-a-modern-twist/175196/" >Sonic The Hedgehog 2: A retro classic film with a modern twist</a></h3>
                        <div class="jeg_post_meta">
                            
                            <div class="jeg_meta_date"><i class="fa fa-clock-o"></i> March 14, 2022 4:47 pm EDT</div>
                        </div>
                        <div class="jeg_post_excerpt">
                            <p>...</p>
                        </div>
                    </div>
                </article><article class="jeg_post jeg_pl_md_4 format-standard">
                    <div class="jeg_thumb">
                        
                        <a href="https://newsdio.com/outlander-season-6-trailer-the-frasers-return-to-scotland/175198/"><div class="thumbnail-container  size-715 "><img width="350" height="250" src="https://newsdio.com/wp-content/uploads/2022/03/Outlander-season-6-2-350x250.jpg" class="attachment-jnews-350x250 size-jnews-350x250 wp-post-image" alt="Outlander Season 6" srcset="https://newsdio.com/wp-content/uploads/2022/03/Outlander-season-6-2-350x250.jpg 350w, https://newsdio.com/wp-content/uploads/2022/03/Outlander-season-6-2-120x86.jpg 120w, https://newsdio.com/wp-content/uploads/2022/03/Outlander-season-6-2-750x536.jpg 750w, https://newsdio.com/wp-content/uploads/2022/03/Outlander-season-6-2-1140x815.jpg 1140w" sizes="(max-width: 350px) 100vw, 350px" /></div></a>
                    </div>
                    <div class="jeg_postblock_content">
                        <div class="jeg_post_category">
                            <span><a href="https://newsdio.com/category/entertainment/">Entertainment</a></span>
                        </div>
                        <h3 class="jeg_post_title"><a href="https://newsdio.com/outlander-season-6-trailer-the-frasers-return-to-scotland/175198/" >Outlander Season 6 Trailer: The Fraser&#8217;s Return to Scotland</a></h3>
                        <div class="jeg_post_meta">
                            
                            <div class="jeg_meta_date"><i class="fa fa-clock-o"></i> March 14, 2022 4:30 pm EDT</div>
                        </div>
                        <div class="jeg_post_excerpt">
                            <p>...</p>
                        </div>
                    </div>
                </article><article class="jeg_post jeg_pl_md_4 format-standard">
                    <div class="jeg_thumb">
                        
                        <a href="https://newsdio.com/batman-the-dark-knight-of-gotham-city/175203/"><div class="thumbnail-container  size-715 "><img width="350" height="250" src="https://newsdio.com/wp-content/uploads/2022/03/The-Batman-1-350x250.png" class="attachment-jnews-350x250 size-jnews-350x250 wp-post-image" alt="The Batman" srcset="https://newsdio.com/wp-content/uploads/2022/03/The-Batman-1-350x250.png 350w, https://newsdio.com/wp-content/uploads/2022/03/The-Batman-1-120x86.png 120w" sizes="(max-width: 350px) 100vw, 350px" /></div></a>
                    </div>
                    <div class="jeg_postblock_content">
                        <div class="jeg_post_category">
                            <span><a href="https://newsdio.com/category/entertainment/">Entertainment</a></span>
                        </div>
                        <h3 class="jeg_post_title"><a href="https://newsdio.com/batman-the-dark-knight-of-gotham-city/175203/" >Batman: The Dark Knight of Gotham City</a></h3>
                        <div class="jeg_post_meta">
                            
                            <div class="jeg_meta_date"><i class="fa fa-clock-o"></i> March 14, 2022 4:16 pm EDT</div>
                        </div>
                        <div class="jeg_post_excerpt">
                            <p>...</p>
                        </div>
                    </div>
                </article></div>
                    <div class='module-overlay'>
				    <div class='preloader_type preloader_dot'>
				        <div class="module-preloader jeg_preloader dot">
				            <span></span><span></span><span></span>
				        </div>
				        <div class="module-preloader jeg_preloader circle">
				            <div class="jnews_preloader_circle_outer">
				                <div class="jnews_preloader_circle_inner"></div>
				            </div>
				        </div>
				        <div class="module-preloader jeg_preloader square">
				            <div class="jeg_square">
				                <div class="jeg_square_inner"></div>
				            </div>
				        </div>
				    </div>
				</div>
                </div>
                <div class="jeg_block_navigation">
                    <div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div>
                    
                    
                </div>
                    
                    <script>var jnews_module_175200_2_622fe71893a44 = {"header_icon":"","first_title":"Related","second_title":" Posts","url":"","header_type":"heading_7","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"All","post_type":"post","content_type":"all","number_post":"4","post_offset":0,"unique_content":"unique1","include_post":"","exclude_post":"175200","include_category":"22903","exclude_category":"","include_author":"","include_tag":"","exclude_tag":"","sort_by":"latest","date_format":"default","date_format_custom":"Y\/m\/d","excerpt_length":"","excerpt_ellipsis":"...","force_normal_image_load":"","pagination_mode":"disable","pagination_nextprev_showtext":"","pagination_number_post":"4","pagination_scroll_limit":3,"boxed":"","boxed_shadow":"","el_id":"","el_class":"","scheme":"","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","paged":1,"column_class":"jeg_col_2o3","class":"jnews_block_27"};</script>
                </div></div><div class='jnews-autoload-splitter'  data-url="https://newsdio.com/the-man-who-fell-to-earth-ejiofor-talks-about-the-upcoming-film-2/175200/" data-title="The Man Who Fell to Earth: Ejiofor talks about the upcoming film" data-id="175200"  data-prev="https://newsdio.com/sonic-the-hedgehog-2-a-retro-classic-film-with-a-modern-twist/175196/" ></div><div class="jnews_popup_post_container"></div><div class="jnews_comment_container"></div>					</div>

				</div>
				
<div class="jeg_sidebar  jeg_sticky_sidebar col-md-4">
    <div class="jegStickyHolder"><div class="theiaStickySidebar"><div class="widget widget_jnews_module_element_ads" id="jnews_module_element_ads-3"><div  class='jeg_ad jeg_ad_module jnews_module_175200_3_622fe71898ac2   '><div class='ads-wrapper'></div></div></div><div class="widget widget_jnews_module_block_21" id="jnews_module_block_21-3"><div  class="jeg_postblock_21 jeg_postblock jeg_module_hook jeg_pagination_disable jeg_col_1o3 jnews_module_175200_4_622fe71898dea   " data-unique="jnews_module_175200_4_622fe71898dea">
					
					<div class="jeg_block_container">
                    
                    <div class="jeg_posts jeg_load_more_flag"><article class="jeg_post jeg_pl_sm format-standard">
                    <div class="jeg_thumb">
                        
                        <a href="https://newsdio.com/obi-wan-kenobi-what-we-know-about-the-upcoming-series-so-far/175209/"><div class="thumbnail-container  size-715 "><img width="120" height="86" src="https://newsdio.com/wp-content/uploads/2022/03/Obi-Wan-Kenobi-120x86.jpg" class="attachment-jnews-120x86 size-jnews-120x86 wp-post-image" alt="Obi-Wan Kenobi" srcset="https://newsdio.com/wp-content/uploads/2022/03/Obi-Wan-Kenobi-120x86.jpg 120w, https://newsdio.com/wp-content/uploads/2022/03/Obi-Wan-Kenobi-350x250.jpg 350w, https://newsdio.com/wp-content/uploads/2022/03/Obi-Wan-Kenobi-750x536.jpg 750w" sizes="(max-width: 120px) 100vw, 120px" /></div></a>
                    </div>
                    <div class="jeg_postblock_content">
                        <h3 class="jeg_post_title">
                            <a href="https://newsdio.com/obi-wan-kenobi-what-we-know-about-the-upcoming-series-so-far/175209/">Obi-Wan Kenobi: What We Know About the Upcoming Series So Far</a>
                        </h3>
                        <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://newsdio.com/obi-wan-kenobi-what-we-know-about-the-upcoming-series-so-far/175209/" ><i class="fa fa-clock-o"></i> March 14, 2022 9:07 pm EDT</a></div></div>
                    </div>
                </article><article class="jeg_post jeg_pl_sm format-standard">
                    <div class="jeg_thumb">
                        
                        <a href="https://newsdio.com/the-man-who-fell-to-earth-ejiofor-talks-about-the-upcoming-film-2/175200/"><div class="thumbnail-container  size-715 "><img width="120" height="86" src="https://newsdio.com/wp-content/uploads/2022/03/The-Man-Who-Fell-to-Earth-120x86.webp" class="attachment-jnews-120x86 size-jnews-120x86 wp-post-image" alt="The Man Who Fell to Earth" srcset="https://newsdio.com/wp-content/uploads/2022/03/The-Man-Who-Fell-to-Earth-120x86.webp 120w, https://newsdio.com/wp-content/uploads/2022/03/The-Man-Who-Fell-to-Earth-350x250.webp 350w, https://newsdio.com/wp-content/uploads/2022/03/The-Man-Who-Fell-to-Earth-750x536.webp 750w, https://newsdio.com/wp-content/uploads/2022/03/The-Man-Who-Fell-to-Earth-1140x815.webp 1140w" sizes="(max-width: 120px) 100vw, 120px" /></div></a>
                    </div>
                    <div class="jeg_postblock_content">
                        <h3 class="jeg_post_title">
                            <a href="https://newsdio.com/the-man-who-fell-to-earth-ejiofor-talks-about-the-upcoming-film-2/175200/">The Man Who Fell to Earth: Ejiofor talks about the upcoming film</a>
                        </h3>
                        <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://newsdio.com/the-man-who-fell-to-earth-ejiofor-talks-about-the-upcoming-film-2/175200/" ><i class="fa fa-clock-o"></i> March 14, 2022 5:03 pm EDT</a></div></div>
                    </div>
                </article><article class="jeg_post jeg_pl_sm format-standard">
                    <div class="jeg_thumb">
                        
                        <a href="https://newsdio.com/sonic-the-hedgehog-2-a-retro-classic-film-with-a-modern-twist/175196/"><div class="thumbnail-container  size-715 "><img width="120" height="86" src="https://newsdio.com/wp-content/uploads/2022/03/Sonic-the-Hedgehog-2-1-120x86.jpg" class="attachment-jnews-120x86 size-jnews-120x86 wp-post-image" alt="Sonic The Hedgehog 2" /></div></a>
                    </div>
                    <div class="jeg_postblock_content">
                        <h3 class="jeg_post_title">
                            <a href="https://newsdio.com/sonic-the-hedgehog-2-a-retro-classic-film-with-a-modern-twist/175196/">Sonic The Hedgehog 2: A retro classic film with a modern twist</a>
                        </h3>
                        <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://newsdio.com/sonic-the-hedgehog-2-a-retro-classic-film-with-a-modern-twist/175196/" ><i class="fa fa-clock-o"></i> March 14, 2022 4:47 pm EDT</a></div></div>
                    </div>
                </article><article class="jeg_post jeg_pl_sm format-standard">
                    <div class="jeg_thumb">
                        
                        <a href="https://newsdio.com/outlander-season-6-trailer-the-frasers-return-to-scotland/175198/"><div class="thumbnail-container  size-715 "><img width="120" height="86" src="https://newsdio.com/wp-content/uploads/2022/03/Outlander-season-6-2-120x86.jpg" class="attachment-jnews-120x86 size-jnews-120x86 wp-post-image" alt="Outlander Season 6" srcset="https://newsdio.com/wp-content/uploads/2022/03/Outlander-season-6-2-120x86.jpg 120w, https://newsdio.com/wp-content/uploads/2022/03/Outlander-season-6-2-350x250.jpg 350w, https://newsdio.com/wp-content/uploads/2022/03/Outlander-season-6-2-750x536.jpg 750w, https://newsdio.com/wp-content/uploads/2022/03/Outlander-season-6-2-1140x815.jpg 1140w" sizes="(max-width: 120px) 100vw, 120px" /></div></a>
                    </div>
                    <div class="jeg_postblock_content">
                        <h3 class="jeg_post_title">
                            <a href="https://newsdio.com/outlander-season-6-trailer-the-frasers-return-to-scotland/175198/">Outlander Season 6 Trailer: The Fraser&#8217;s Return to Scotland</a>
                        </h3>
                        <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://newsdio.com/outlander-season-6-trailer-the-frasers-return-to-scotland/175198/" ><i class="fa fa-clock-o"></i> March 14, 2022 4:30 pm EDT</a></div></div>
                    </div>
                </article><article class="jeg_post jeg_pl_sm format-standard">
                    <div class="jeg_thumb">
                        
                        <a href="https://newsdio.com/batman-the-dark-knight-of-gotham-city/175203/"><div class="thumbnail-container  size-715 "><img width="120" height="86" src="https://newsdio.com/wp-content/uploads/2022/03/The-Batman-1-120x86.png" class="attachment-jnews-120x86 size-jnews-120x86 wp-post-image" alt="The Batman" srcset="https://newsdio.com/wp-content/uploads/2022/03/The-Batman-1-120x86.png 120w, https://newsdio.com/wp-content/uploads/2022/03/The-Batman-1-350x250.png 350w" sizes="(max-width: 120px) 100vw, 120px" /></div></a>
                    </div>
                    <div class="jeg_postblock_content">
                        <h3 class="jeg_post_title">
                            <a href="https://newsdio.com/batman-the-dark-knight-of-gotham-city/175203/">Batman: The Dark Knight of Gotham City</a>
                        </h3>
                        <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://newsdio.com/batman-the-dark-knight-of-gotham-city/175203/" ><i class="fa fa-clock-o"></i> March 14, 2022 4:16 pm EDT</a></div></div>
                    </div>
                </article><article class="jeg_post jeg_pl_sm format-standard">
                    <div class="jeg_thumb">
                        
                        <a href="https://newsdio.com/the-mysterious-and-engaging-world-of-the-umbrella-academy/175193/"><div class="thumbnail-container  size-715 "><img width="120" height="86" src="https://newsdio.com/wp-content/uploads/2022/03/the-umbrella-academy-120x86.jpeg" class="attachment-jnews-120x86 size-jnews-120x86 wp-post-image" alt="the umbrella academy" srcset="https://newsdio.com/wp-content/uploads/2022/03/the-umbrella-academy-120x86.jpeg 120w, https://newsdio.com/wp-content/uploads/2022/03/the-umbrella-academy-350x250.jpeg 350w" sizes="(max-width: 120px) 100vw, 120px" /></div></a>
                    </div>
                    <div class="jeg_postblock_content">
                        <h3 class="jeg_post_title">
                            <a href="https://newsdio.com/the-mysterious-and-engaging-world-of-the-umbrella-academy/175193/">The Mysterious and Engaging World of The Umbrella Academy</a>
                        </h3>
                        <div class="jeg_post_meta"><div class="jeg_meta_date"><a href="https://newsdio.com/the-mysterious-and-engaging-world-of-the-umbrella-academy/175193/" ><i class="fa fa-clock-o"></i> March 14, 2022 3:44 pm EDT</a></div></div>
                    </div>
                </article></div>
                    <div class='module-overlay'>
				    <div class='preloader_type preloader_dot'>
				        <div class="module-preloader jeg_preloader dot">
				            <span></span><span></span><span></span>
				        </div>
				        <div class="module-preloader jeg_preloader circle">
				            <div class="jnews_preloader_circle_outer">
				                <div class="jnews_preloader_circle_inner"></div>
				            </div>
				        </div>
				        <div class="module-preloader jeg_preloader square">
				            <div class="jeg_square">
				                <div class="jeg_square_inner"></div>
				            </div>
				        </div>
				    </div>
				</div>
                </div>
                <div class="jeg_block_navigation">
                    <div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div>
                    
                    
                </div>
					
					<script>var jnews_module_175200_4_622fe71898dea = {"header_icon":"","first_title":"","second_title":"","url":"","header_type":"heading_6","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"All","post_type":"post","content_type":"all","number_post":6,"post_offset":0,"unique_content":"disable","include_post":"","exclude_post":"","include_category":"","exclude_category":"","include_author":"","include_tag":"","exclude_tag":"","sort_by":"latest","date_format":"default","date_format_custom":"Y\/m\/d","force_normal_image_load":"","pagination_mode":"disable","pagination_nextprev_showtext":"","pagination_number_post":6,"pagination_scroll_limit":0,"boxed":"","boxed_shadow":"","el_id":"","el_class":"","scheme":"","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","paged":1,"column_class":"jeg_col_1o3","class":"jnews_block_21"};</script>
				</div></div><div class="widget widget_jnews_module_block_28" id="jnews_module_block_28-3"><div  class="jeg_postblock_28 jeg_postblock jeg_module_hook jeg_pagination_disable jeg_col_1o3 jnews_module_175200_5_622fe7189afd1   " data-unique="jnews_module_175200_5_622fe7189afd1">
					
					<div class="jeg_block_container">
                    
                    <div class="jeg_posts ">
                    <div class="jeg_postsmall jeg_load_more_flag">
                        <article class="jeg_post jeg_pl_xs_4 format-standard">
                    <div class="jeg_postblock_content">
                        <h3 class="jeg_post_title">
                            <a href="https://newsdio.com/obi-wan-kenobi-what-we-know-about-the-upcoming-series-so-far/175209/">Obi-Wan Kenobi: What We Know About the Upcoming Series So Far</a>
                        </h3>
                        
                    </div>
                </article><article class="jeg_post jeg_pl_xs_4 format-standard">
                    <div class="jeg_postblock_content">
                        <h3 class="jeg_post_title">
                            <a href="https://newsdio.com/the-man-who-fell-to-earth-ejiofor-talks-about-the-upcoming-film-2/175200/">The Man Who Fell to Earth: Ejiofor talks about the upcoming film</a>
                        </h3>
                        
                    </div>
                </article><article class="jeg_post jeg_pl_xs_4 format-standard">
                    <div class="jeg_postblock_content">
                        <h3 class="jeg_post_title">
                            <a href="https://newsdio.com/sonic-the-hedgehog-2-a-retro-classic-film-with-a-modern-twist/175196/">Sonic The Hedgehog 2: A retro classic film with a modern twist</a>
                        </h3>
                        
                    </div>
                </article><article class="jeg_post jeg_pl_xs_4 format-standard">
                    <div class="jeg_postblock_content">
                        <h3 class="jeg_post_title">
                            <a href="https://newsdio.com/outlander-season-6-trailer-the-frasers-return-to-scotland/175198/">Outlander Season 6 Trailer: The Fraser&#8217;s Return to Scotland</a>
                        </h3>
                        
                    </div>
                </article><article class="jeg_post jeg_pl_xs_4 format-standard">
                    <div class="jeg_postblock_content">
                        <h3 class="jeg_post_title">
                            <a href="https://newsdio.com/batman-the-dark-knight-of-gotham-city/175203/">Batman: The Dark Knight of Gotham City</a>
                        </h3>
                        
                    </div>
                </article><article class="jeg_post jeg_pl_xs_4 format-standard">
                    <div class="jeg_postblock_content">
                        <h3 class="jeg_post_title">
                            <a href="https://newsdio.com/the-mysterious-and-engaging-world-of-the-umbrella-academy/175193/">The Mysterious and Engaging World of The Umbrella Academy</a>
                        </h3>
                        
                    </div>
                </article>
                    </div>
                </div>
                    <div class='module-overlay'>
				    <div class='preloader_type preloader_dot'>
				        <div class="module-preloader jeg_preloader dot">
				            <span></span><span></span><span></span>
				        </div>
				        <div class="module-preloader jeg_preloader circle">
				            <div class="jnews_preloader_circle_outer">
				                <div class="jnews_preloader_circle_inner"></div>
				            </div>
				        </div>
				        <div class="module-preloader jeg_preloader square">
				            <div class="jeg_square">
				                <div class="jeg_square_inner"></div>
				            </div>
				        </div>
				    </div>
				</div>
                </div>
                <div class="jeg_block_navigation">
                    <div class='navigation_overlay'><div class='module-preloader jeg_preloader'><span></span><span></span><span></span></div></div>
                    
                    
                </div>
					
					<script>var jnews_module_175200_5_622fe7189afd1 = {"header_icon":"","first_title":"","second_title":"","url":"","header_type":"heading_6","header_background":"","header_secondary_background":"","header_text_color":"","header_line_color":"","header_accent_color":"","header_filter_category":"","header_filter_author":"","header_filter_tag":"","header_filter_text":"All","post_type":"post","content_type":"all","number_post":6,"post_offset":0,"unique_content":"disable","include_post":"","exclude_post":"","include_category":"","exclude_category":"","include_author":"","include_tag":"","exclude_tag":"","sort_by":"latest","show_date":"","date_format":"default","date_format_custom":"Y\/m\/d","pagination_mode":"disable","pagination_nextprev_showtext":"","pagination_number_post":4,"pagination_scroll_limit":0,"ads_type":"disable","ads_position":1,"ads_random":"","ads_image":"","ads_image_tablet":"","ads_image_phone":"","ads_image_link":"","ads_image_alt":"","ads_image_new_tab":"","google_publisher_id":"","google_slot_id":"","google_desktop":"auto","google_tab":"auto","google_phone":"auto","content":"","ads_bottom_text":"","boxed":"","boxed_shadow":"","show_border":"","el_id":"","el_class":"","scheme":"","column_width":"auto","title_color":"","accent_color":"","alt_color":"","excerpt_color":"","css":"","paged":1,"column_class":"jeg_col_1o3","class":"jnews_block_28"};</script>
				</div></div></div></div></div>			</div>

		
		<div class="jeg_ad jeg_article jnews_article_bottom_ads">
			<div class='ads-wrapper  '></div>		</div>

	</div>

</div>
                </div>
            </div>

            <div id="post-body-class" class="post-template-default single single-post postid-175200 single-format-standard wp-embed-responsive jeg_toggle_dark jeg_single_tpl_2 jnews jnews_boxed_container jnews_boxed_container_shadow jsc_normal elementor-default elementor-kit-151634"></div>

            
        </div>

        <div class="post-ajax-overlay">
    <div class="preloader_type preloader_dot">
        <div class="newsfeed_preloader jeg_preloader dot">
            <span></span><span></span><span></span>
        </div>
        <div class="newsfeed_preloader jeg_preloader circle">
            <div class="jnews_preloader_circle_outer">
                <div class="jnews_preloader_circle_inner"></div>
            </div>
        </div>
        <div class="newsfeed_preloader jeg_preloader square">
            <div class="jeg_square"><div class="jeg_square_inner"></div></div>
        </div>
    </div>
</div>
    </div>
        <div class="footer-holder" id="footer" data-id="footer">
            <div class="jeg_footer jeg_footer_6 dark">
    <div class="jeg_footer_container jeg_container_full">

        <div class="jeg_footer_content">
            <div class="container">
                <div class="jeg_footer_primary clearfix">
                    <div class="footer_widget widget_text" id="text-16">			<div class="textwidget"><p><img loading="lazy" class="alignnone size-full wp-image-167332" src="https://newsdio.com/wp-content/uploads/2021/10/images.png" alt="" width="290" height="93" /></p>
<p>NewsDio.com is Famous News website which is operates from 5 years. Email : <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="e09382818e95d0d3d4a0878d81898cce838f8d">[email&#160;protected]</a></p>
</div>
		</div>                </div>
            </div>
        </div>

                            <div class="jeg_footer_instagram_wrapper jeg_container">
                                            </div>
                                    <div class="jeg_footer_tiktok_wrapper jeg_container">
                                            </div>
                
        
        <div class="jeg_footer_bottom">
            <div class="container">

                <!-- secondary footer right -->
                <div class="footer_right">

                    
                    <ul class="jeg_menu_footer"><li id="menu-item-151747" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-151747"><a href="https://newsdio.com/category/technology/">Technology</a></li>
<li id="menu-item-151748" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151748"><a href="https://newsdio.com/category/news/">News</a></li>
<li id="menu-item-151749" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151749"><a href="https://newsdio.com/category/sports/">Sports</a></li>
<li id="menu-item-151751" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151751"><a href="https://newsdio.com/category/education/">Education</a></li>
<li id="menu-item-151767" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151767"><a href="https://newsdio.com/category/finance/">Finance</a></li>
<li id="menu-item-151768" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151768"><a href="https://newsdio.com/category/health/">Health</a></li>
<li id="menu-item-151769" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151769"><a href="https://newsdio.com/category/gaming/">Gaming</a></li>
<li id="menu-item-151770" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-151770"><a href="https://newsdio.com/category/featured/movies/">Movies</a></li>
<li id="menu-item-157184" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-157184"><a href="https://newsdio.com/write-for-us/">Write for Us</a></li>
</ul>
                    			<div class="jeg_social_icon_block socials_widget nobg">
				<a href="https://facebook.com" target='_blank' rel='external noopener nofollow' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com" target='_blank' rel='external noopener nofollow' class="jeg_twitter"><i class="fa fa-twitter"></i> </a>			</div>
			
                </div>

                <!-- secondary footer left -->
                
                
                                    <p class="copyright"> © 2021 <a href="https://newsdio.com" title="NewsDio">NewsDio</a>. </p>
                
            </div>
        </div>

        
    </div>
</div><!-- /.footer -->        </div>

        <div class="jscroll-to-top">
        	<a href="#back-to-top" class="jscroll-to-top_link"><i class="fa fa-angle-up"></i></a>
        </div>
    </div>

    <!-- Mobile Navigation
    ============================================= -->
<div id="jeg_off_canvas" class="normal">
    <a href="#" class="jeg_menu_close"><i class="jegicon-cross"></i></a>
    <div class="jeg_bg_overlay"></div>
    <div class="jeg_mobile_wrapper">
        <div class="nav_wrap">
    <div class="item_main">
        <!-- Search Form -->
<div class="jeg_aside_item jeg_search_wrapper jeg_search_no_expand round">
    <a href="#" class="jeg_search_toggle"><i class="fa fa-search"></i></a>
    <form action="https://newsdio.com/" method="get" class="jeg_search_form" target="_top">
    <input name="s" class="jeg_search_input" placeholder="Search..." type="text" value="" autocomplete="off">
    <button aria-label="Search Button" type="submit" class="jeg_search_button btn"><i class="fa fa-search"></i></button>
</form>
<!-- jeg_search_hide with_result no_result -->
<div class="jeg_search_result jeg_search_hide with_result">
    <div class="search-result-wrapper">
    </div>
    <div class="search-link search-noresult">
        No Result    </div>
    <div class="search-link search-all-button">
        <i class="fa fa-search"></i> View All Result    </div>
</div></div><div class="jeg_aside_item">
    <ul class="jeg_mobile_menu"><li id="menu-item-163382" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-163382"><a href="https://newsdio.com/category/entertainment/">Entertainment</a></li>
<li id="menu-item-163383" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163383"><a href="https://newsdio.com/category/technology/">Technology</a></li>
<li id="menu-item-163384" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163384"><a href="https://newsdio.com/category/featured/movies/">Movies</a></li>
<li id="menu-item-163385" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163385"><a href="https://newsdio.com/category/news/">News</a></li>
<li id="menu-item-163386" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163386"><a href="https://newsdio.com/category/finance/">Finance</a></li>
<li id="menu-item-163387" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163387"><a href="https://newsdio.com/category/sports/">Sports</a></li>
<li id="menu-item-163388" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163388"><a href="https://newsdio.com/category/health/">Health</a></li>
<li id="menu-item-163389" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-163389"><a href="https://newsdio.com/write-for-us/">Write for Us</a></li>
<li id="menu-item-163390" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-163390"><a href="https://newsdio.com/">Home</a></li>
</ul></div>    </div>
    <div class="item_bottom">
        <div class="jeg_aside_item socials_widget nobg">
    <a href="https://facebook.com" target='_blank' rel='external noopener nofollow' class="jeg_facebook"><i class="fa fa-facebook"></i> </a><a href="https://twitter.com" target='_blank' rel='external noopener nofollow' class="jeg_twitter"><i class="fa fa-twitter"></i> </a></div><div class="jeg_aside_item jeg_aside_copyright">
	<p>© 2021 <a href="https://newsdio.com" title="NewsDio">NewsDio</a>.</p>
</div>    </div>
</div>    </div>
</div><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="text/javascript">var jfla = ["view_counter"]</script><div id="selectShareContainer">
                        <div class="selectShare-inner">
                            <div class="select_share jeg_share_button">              
                                <button class="select-share-button jeg_btn-facebook" data-url="http://www.facebook.com/sharer.php?u=[url]&quote=[selected_text]" data-post-url="https%3A%2F%2Fnewsdio.com%2Fthe-man-who-fell-to-earth-ejiofor-talks-about-the-upcoming-film-2%2F175200%2F" data-image-url="" data-title="The%20Man%20Who%20Fell%20to%20Earth%3A%20Ejiofor%20talks%20about%20the%20upcoming%20film" ><i class="fa fa-facebook-official"></i></a><button class="select-share-button jeg_btn-twitter" data-url="https://twitter.com/intent/tweet?text=[selected_text]&url=[url]" data-post-url="https%3A%2F%2Fnewsdio.com%2Fthe-man-who-fell-to-earth-ejiofor-talks-about-the-upcoming-film-2%2F175200%2F" data-image-url="" data-title="The%20Man%20Who%20Fell%20to%20Earth%3A%20Ejiofor%20talks%20about%20the%20upcoming%20film" ><i class="fa fa-twitter"></i></a>
                            </div>
                            <div class="selectShare-arrowClip">
                                <div class="selectShare-arrow"></div>      
                            </div> 
                        </div>      
                      </div><div class="jeg_read_progress_wrapper"><div class="jeg_progress_container top"><span class="progress-bar"></span></div></div><script type='text/javascript' src='https://newsdio.com/wp-content/plugins/jnews-auto-load-post/assets/js/jquery.autoload.js' id='jnews-autoload-js'></script>
<script type='text/javascript' src='https://newsdio.com/wp-includes/js/comment-reply.min.js?ver=5.8.4' id='comment-reply-js'></script>
<script type='text/javascript' src='https://newsdio.com/wp-includes/js/hoverIntent.min.js?ver=1.10.1' id='hoverIntent-js'></script>
<script type='text/javascript' src='https://newsdio.com/wp-includes/js/imagesloaded.min.js?ver=4.1.4' id='imagesloaded-js'></script>
<script type='text/javascript' id='jnews-frontend-js-extra'>
/* <![CDATA[ */
var jnewsoption = {"login_reload":"https:\/\/newsdio.com\/the-man-who-fell-to-earth-ejiofor-talks-about-the-upcoming-film-2\/175200","popup_script":"magnific","single_gallery":"","ismobile":"","isie":"","sidefeed_ajax":"","language":"en_US","module_prefix":"jnews_module_ajax_","live_search":"1","postid":"175200","isblog":"1","admin_bar":"0","follow_video":"","follow_position":"bottom_right","rtl":"0","gif":"","lang":{"invalid_recaptcha":"Invalid Recaptcha!","empty_username":"Please enter your username!","empty_email":"Please enter your email!","empty_password":"Please enter your password!"},"recaptcha":"0","site_slug":"\/","site_domain":"newsdio.com","zoom_button":"0","autoload_limit":"10","autoload_content":"category"};
/* ]]> */
</script>
<script type='text/javascript' src='https://newsdio.com/wp-content/themes/jnews/assets/dist/frontend.min.js?ver=10.0.9' id='jnews-frontend-js'></script>
<!--[if lt IE 9]>
<script type='text/javascript' src='https://newsdio.com/wp-content/themes/jnews/assets/js/html5shiv.min.js?ver=10.0.9' id='html5shiv-js'></script>
<![endif]-->
<script type='text/javascript' id='jnews-select-share-js-extra'>
/* <![CDATA[ */
var jnews_select_share = {"is_customize_preview":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://newsdio.com/wp-content/plugins/jnews-social-share/assets/js/plugin.js' id='jnews-select-share-js'></script>
<script type='text/javascript' src='https://newsdio.com/wp-includes/js/wp-embed.min.js?ver=5.8.4' id='wp-embed-js'></script>
<div class="jeg_ad jnews_mobile_sticky_ads "></div><script type='application/ld+json'>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</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"hentry","entry-title":"The Man Who Fell to Earth: Ejiofor talks about the upcoming film","published":"2022-03-14 17:03:40","updated":"2022-03-14 20:04:45"}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https:\/\/newsdio.com","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@id":"https:\/\/newsdio.com\/category\/entertainment\/","name":"Entertainment"}},{"@type":"ListItem","position":3,"item":{"@id":"https:\/\/newsdio.com","name":"Home"}},{"@type":"ListItem","position":4,"item":{"@id":"https:\/\/newsdio.com\/category\/entertainment\/","name":"Entertainment"}}]}</script>
<script type="text/javascript">;!function(){"use strict";window.jnews=window.jnews||{},window.jnews.first_load=window.jnews.first_load||{},window.jnews.first_load=function(){var e=this,t=jnews.library,n="object"==typeof jnews&&"object"==typeof jnews.library;e.data=null,e.run_ajax=!0,e.run_loginregister=!0,e.clear=function(){e.run_ajax=!0,e.run_loginregister=!0,e.data=null},e.init=function(){n&&(t.globalBody.querySelectorAll(".jeg_popup_account").length&&jnews.loginregister&&e.run_loginregister&&(e.run_loginregister=!1,jnews.loginregister.init(),jnews.loginregister.hook_form()),jfla.length&&e.run_ajax&&(e.run_ajax=!1,e.do_ajax({action:"jnews_first_load_action",jnews_id:jnewsoption.postid,load_action:jfla})))},e.update_counter=function(){if(n){var o={total_view:t.globalBody.querySelectorAll(".jeg_share_stats .jeg_views_count .counts"),total_share:t.globalBody.querySelectorAll(".jeg_share_stats .jeg_share_count .counts"),total_comment:t.globalBody.querySelectorAll(".jeg_meta_comment a span")};t.forEach(Object.entries(e.data.counter),(function([e,n]){o[e].length&&t.forEach(o[e],(function(e,o){t.setText(e,n)}))}))}},e.do_ajax=function(o){if(n){var a=new XMLHttpRequest;a.onreadystatechange=function(){XMLHttpRequest.DONE===a.readyState&&200==a.status&&(e.data=JSON.parse(a.responseText),e.data.counter&&"object"==typeof e.data.counter&&e.update_counter())},a.open("POST",jnews_ajax_url,!0),a.setRequestHeader("Content-Type","application/x-www-form-urlencoded; charset=UTF-8"),a.send(t.httpBuildQuery(o))}}},window.jnews.first_load=new window.jnews.first_load,jnews.first_load.init()}();</script></body>
</html>

<!-- Cache served by breeze CACHE - Last modified: Tue, 15 Mar 2022 01:08:40 GMT -->
